Page 1 of 1

Eon Steel - new iPhone

Posted: Fri Oct 27, 2017 9:15 pm
by Simone
My iPhone 7 and my Suunto EON Steel had a happy time synching for the last few months. Now, I bought a new iPhone 8+, removed the pairing from the EON, started synchronizing with MacDive on the iPhone 8+, typed in the pairing code, everything OK so far. Then I started synchronizing and saw "Getting dive list ..." for seven hours.

I then tried to go back to the old iPhone, tried to re-boot either iPhone, made the update of the EON to 1.6.4, all to no avail. Synchronizing via the cable on the Mac is no problem, but the iPhones get stuck at "getting dive list".

Any idea?
Cheers, Simone

Re: Eon Steel - new iPhone

Posted: Sat Oct 28, 2017 3:40 am
by nick
No ideas off the top of my head. Usually removing the pairing is enough - might be worth dropping me an email, I’ll send you some debug instructions to see if there’s an error that has occurred and not been handled properly.

I just updated mine and repaired and minus a timeout downloaded 100 odd dives. I’d recommend trying to force restart the app, leave the EON a while and trying again. And if that doesn’t work drop me an email.

Re: Eon Steel - new iPhone

Posted: Tue Oct 31, 2017 4:32 am
by nick
For the forum, there was a rare issue that could occur with a very specific set of data, combined with what was essentially a typo in MacDive, that could trigger an infinite loop. A fix has been pushed to TestFlight.

Most people won't ever encounter this. If you do, a new dive will resolve it. And the next version will fix the problem anyway.

Thanks for reporting this!