MacDive Forums

Discussion and Support for MacDive
It is currently Sat Nov 25, 2017 7:38 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Sep 07, 2017 6:35 am 
Offline

Joined: Thu Sep 07, 2017 6:25 am
Posts: 2
Dive Computer: Suunto
Updated Macdive on my iMac to the most recent version today.

I've had a Vyper and Vytec for many years and used them with Mac dive. It's been 2 years since I've downloaded, but now I get a -5 error. it appears the serial port will not open.

Is this due to the new OS or support for Suunto?

Here is my log:

XXXXXXXX:Desktop XXXXXXXX$ ./dctool -v -l dctool.log -d "Suunto Vyper" dump -o dctool.bin /dev/tty.ThunderFlash-SPPDev-1
DATETIME 2017-09-06T21:56:46Z (1504735006)
VERSION 0.6.0-devel (156f54302d603e6231d2c599bfedd8068d7abbe4)
Opening the device (Suunto Vyper, /dev/tty.ThunderFlash-SPPDev-1).
INFO: Open: name=/dev/tty.ThunderFlash-SPPDev-1
ERROR: Resource busy (16) [in ../../source/src/serial_posix.c:175 (dc_serial_open)]
ERROR: Failed to open the serial port. [in ../../source/src/suunto_vyper.c:112 (suunto_vyper_device_open)]
ERROR: Error opening the device. [in ../../source/examples/dctool_dump.c:55 (dump)]
ERROR: Access denied

Thanks.


Top
 Profile  
 
PostPosted: Thu Sep 07, 2017 7:51 am 
Offline
Site Admin
User avatar

Joined: Sat Apr 12, 2008 8:33 am
Posts: 3496
Dive Computer: Shearwater Perdix AI
Suunto Guy wrote:
Is this due to the new OS or support for Suunto?


Neither. It's because you are using the wrong serial port there. Most likely you didn't install the USB driver. It's linked off the devices page, but here's the direct link:

http://www.ftdichip.com/Drivers/VCP/Mac ... v2_4_2.dmg

Download, install, reboot. Then it should be fine.

_________________
http://www.mac-dive.com : support@mac-dive.com : @MacDiveApp


Top
 Profile  
 
PostPosted: Thu Sep 07, 2017 8:24 am 
Offline

Joined: Thu Sep 07, 2017 6:25 am
Posts: 2
Dive Computer: Suunto
Nick,

Thanks - You are likely correct. I decided to load the Suunto software. In the process of loading the SW, drivers, emulators, etc. I likely downloaded the file you suggested. I ran their SW and it worked, so I tried MacDive and now it works. Thanks for the quick reply. Great program, I didn't want to switch back.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group