MacDive Forums

Discussion and Support for MacDive
It is currently Sat May 26, 2018 12:05 pm

All times are UTC + 8 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Apr 09, 2017 3:17 am 
Offline

Joined: Sun Apr 09, 2017 3:10 am
Posts: 4
Dive Computer: Tusa IQ 950
Hello,
I have a Mac running OSX 10.11.6 (el Capitan). I purchased MacDive (v 2.8.1) and followed the directions to install the drivers and virtual serial port. When I try to Download Dives, I receive the following error:

MacDive encountered a problem downloading from your Tusa IQ950 (Zen Air):

Failed connecting to dive computer on serial port '/dev/tty.usbserial-20030001' (Error Code: -7)

When I try the other port, I receive the same error but for the other port:

MacDive encountered a problem downloading from your Tusa IQ950 (Zen Air):

Failed connecting to dive computer on serial port '/dev/tty.serial1' (Error Code: -7)



Thoughts?

Thanks,
Brian


Top
 Profile  
 
PostPosted: Sun Apr 09, 2017 5:00 am 
Offline
Site Admin
User avatar

Joined: Sat Apr 12, 2008 8:33 am
Posts: 3621
Dive Computer: Shearwater Perdix AI
usbserial-20030001 is the correct port.

Failed to connect is most likely either the cable is plugged in upside down or you have a low battery. If there's anything else open and using it, that could cause the connection to fail also.

_________________
http://www.mac-dive.com : support@mac-dive.com : @MacDiveApp


Top
 Profile  
 
PostPosted: Tue Apr 11, 2017 9:44 am 
Offline

Joined: Sun Apr 09, 2017 3:10 am
Posts: 4
Dive Computer: Tusa IQ 950
The dive computer switches to PC mode and when I try other dive log programs, it can download the dives. When I try to download dives in Mac-Dive it doesn't work. I can use other programs, but I don't want to use other programs. I've tried everything I can think of and now I'm thinking I spent money on a program I can't use. :cry:


Top
 Profile  
 
PostPosted: Tue Apr 11, 2017 10:07 am 
Offline
Site Admin
User avatar

Joined: Sat Apr 12, 2008 8:33 am
Posts: 3621
Dive Computer: Shearwater Perdix AI
The device is well supported, so the issue is on your end with the connection.

Make sure you do not have any other apps running that may interfere This, along with low battery/a bad connection are the common causes. The simplest thing to do is ensure you have cleared out your preference under advanced, where you chose the wrong one, and then reboot.

Thanks.

_________________
http://www.mac-dive.com : support@mac-dive.com : @MacDiveApp


Top
 Profile  
 
PostPosted: Tue Apr 11, 2017 11:03 am 
Offline

Joined: Sun Apr 09, 2017 3:10 am
Posts: 4
Dive Computer: Tusa IQ 950
I've tried everything. The Dive computer has a good battery and there are no other programs running. If you say it's on my end, I believe you but that does not actually fix the problem. I can connect to other programs and download the dive data. When it comes to Mac-Dive, it does not work. At this point, I'll believe others who say you have a good program but to me, I lost good money buying it.


Top
 Profile  
 
PostPosted: Tue Apr 11, 2017 11:17 am 
Offline
Site Admin
User avatar

Joined: Sat Apr 12, 2008 8:33 am
Posts: 3621
Dive Computer: Shearwater Perdix AI
Can you please try:

Tools > Send Diagnostic Info

Choose "atom2" as the device type. Follow the instructions and click Email when it is complete.

Thank You.
MacDive Support

_________________
http://www.mac-dive.com : support@mac-dive.com : @MacDiveApp


Top
 Profile  
 
PostPosted: Tue Apr 11, 2017 1:02 pm 
Offline

Joined: Sun Apr 09, 2017 3:10 am
Posts: 4
Dive Computer: Tusa IQ 950
Email Sent. It also looks like each time I restart the program, it defaults back to: /dev/tty.serial1


Top
 Profile  
 
PostPosted: Tue Apr 11, 2017 1:10 pm 
Offline
Site Admin
User avatar

Joined: Sat Apr 12, 2008 8:33 am
Posts: 3621
Dive Computer: Shearwater Perdix AI
It should not default to anything. You should clear the field out so that MacDive can guess the correct port, which it will do for your device (provided it exists).

Either that, or select /dev/tty.usbserial-2003001 which is the port you want. What is the error indicating? Is it using the correct port?

edit: I just realised you are the person that emailed me a random log. Sorry, I get a lot of email, I didn't make the connection immediately.

_________________
http://www.mac-dive.com : support@mac-dive.com : @MacDiveApp


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 8 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group